Be less restrictive and allow also `perl util/perlpath.pl /path/to/bin/perl'
authorRalf S. Engelschall <rse@openssl.org>
Wed, 10 Mar 1999 19:57:05 +0000 (19:57 +0000)
committerRalf S. Engelschall <rse@openssl.org>
Wed, 10 Mar 1999 19:57:05 +0000 (19:57 +0000)
in addition to `perl util/perlpath.pl /path/to/bin', because this way one can
also use an interpreter named `perl5' (which is usually the name of Perl 5.xxx
on platforms where an Perl 4.x is still installed as `perl').

Submitted by: Matthias Loepfe <Matthias.Loepfe@adnovum.ch>
Reviewed by: Ralf S. Engelschall

CHANGES
util/perlpath.pl

diff --git a/CHANGES b/CHANGES
index b51d031..7abe7b5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -5,6 +5,13 @@
 
  Changes between 0.9.1c and 0.9.2
 
+  *) Be less restrictive and allow also `perl util/perlpath.pl
+     /path/to/bin/perl' in addition to `perl util/perlpath.pl /path/to/bin',
+     because this way one can also use an interpreter named `perl5' (which is
+     usually the name of Perl 5.xxx on platforms where an Perl 4.x is still
+     installed as `perl').
+     [Matthias Loepfe <Matthias.Loepfe@adnovum.ch>]
+
   *) Let util/clean-depend.pl work also with older Perl 5.00x versions.
      [Matthias Loepfe <Matthias.Loepfe@adnovum.ch>]
 
index 0aa5ada..a1f236b 100755 (executable)
@@ -17,7 +17,12 @@ sub wanted
        @a=<IN>;
        close(IN);
 
-       $a[0]="#!$ARGV[0]/perl\n";
+       if (-d $ARGV[0]) {
+               $a[0]="#!$ARGV[0]/perl\n";
+       }
+       else {
+               $a[0]="#!$ARGV[0]\n";
+       }
 
        # Playing it safe...
        $new="$_.new";