Let util/clean-depend.pl work also with older Perl 5.00x versions.
authorRalf S. Engelschall <rse@openssl.org>
Wed, 10 Mar 1999 19:51:43 +0000 (19:51 +0000)
committerRalf S. Engelschall <rse@openssl.org>
Wed, 10 Mar 1999 19:51:43 +0000 (19:51 +0000)
Submitted by: Matthias Loepfe <Matthias.Loepfe@adnovum.ch>
Reviewed by: Ralf S. Engelschall

CHANGES
util/clean-depend.pl

diff --git a/CHANGES b/CHANGES
index 95a0bd2..b51d031 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -5,6 +5,9 @@
 
  Changes between 0.9.1c and 0.9.2
 
+  *) Let util/clean-depend.pl work also with older Perl 5.00x versions.
+     [Matthias Loepfe <Matthias.Loepfe@adnovum.ch>]
+
   *) Fix Makefile.org so CC,CFLAG etc are passed to 'make links' add
      advapi32.lib to Win32 build and change the pem test comparision
      to fc.exe (thanks to Ulrich Kroener <kroneru@yahoo.com> for the
index 9f77566..7819dee 100755 (executable)
@@ -19,9 +19,11 @@ while(<STDIN>) {
     push @{$files{$file}},@deps;
 }
 
-foreach my $file (sort keys %files) {
+my $file;
+foreach $file (sort keys %files) {
     my $len=0;
-    foreach my $dep (sort @{$files{$file}}) {
+    my $dep;
+    foreach $dep (sort @{$files{$file}}) {
        $len=0 if $len+length($dep)+1 >= 80;
        if($len == 0) {
            print "\n$file:";