Some platforms (namely HP-UX) require the 'x' bit set for shared libraries.
[openssl.git] / perl / Makefile.PL
index 1f0c44abbf99423c0c3a55b60d06fbc0a410db75..2a67ad061d5cefc1c13bcc1d0e6bb8aac32a239a 100644 (file)
@@ -2,7 +2,11 @@
 ##  Makefile.PL -- Perl MakeMaker specification
 ##
 
-$V = '0.9.2';
+open(IN,"<../Makefile.ssl") || die "unable to open Makefile.ssl!\n";
+while(<IN>) {
+    $V=$1 if (/^VERSION=(.*)$/);
+}
+close(IN);
 print "Configuring companion Perl module for OpenSSL $V\n";
 
 use ExtUtils::MakeMaker;
@@ -18,7 +22,6 @@ WriteMakefile(
     'DEFINE'        => '',
     'INC'           => '-I../include',
     'H'             => ['openssl.h'],
-    'C'             => ['openssl_cb.c'],
     'OBJECT' =>
         'OpenSSL.o ' .
         'openssl_bio.o ' .