'version' is not optional in the encoding