Don't negotiate TLSv1.3 if our EC cert isn't TLSv1.3 capable
[openssl.git] / ssl / methods.c
2017-06-30 Matt CaswellDrop support for OPENSSL_NO_TLS1_3_METHOD
2016-11-02 Matt CaswellAdd the SSL_METHOD for TLSv1.3 and all other base chang...
2016-08-18 Emilia KasperIndent ssl/
2016-08-04 David WoodhouseMake DTLS1_BAD_VER work with DTLS_client_method()
2016-05-17 Rich SalzCopyright consolidation 01/10
2016-03-27 Fedor IndutnyAllow different protocol version when trying to reuse...
2016-03-09 Kurt RoeckxDeprecate the use of version-specific methods
2016-01-26 Rich SalzRemove /* foo.c */ comments
2016-01-19 Viktor DukhovniSupport disabling any or all TLS or DTLS versions
2016-01-02 Viktor DukhovniProtocol version selection and negotiation rewrite
2015-11-05 Matt CaswellEnsure the dtls1_get_*_methods work with DTLS_ANY_VERSION
2015-10-30 Matt CaswellChange statem prefix to ossl_statem
2015-10-30 Matt CaswellReorganise state machine files