Heimdal isn't really supported right now. Say so, and offer a possibility
authorRichard Levitte <levitte@openssl.org>
Tue, 26 Nov 2002 09:19:17 +0000 (09:19 +0000)
committerRichard Levitte <levitte@openssl.org>
Tue, 26 Nov 2002 09:19:17 +0000 (09:19 +0000)
to force the use of Heimdal, and warn if that's used.
PR: 346

Configure

index 0c04460..9c439d9 100755 (executable)
--- a/Configure
+++ b/Configure
@@ -994,6 +994,17 @@ else
        my ($lresolv, $lpath, $lext);
        if ($withargs{"krb5-flavor"} =~ /^[Hh]eimdal$/)
                {
+               die "Sorry, Heimdal is currently not supported\n";
+               }
+       ##### HACK to force use of Heimdal.
+       ##### WARNING: Since we don't really have adequate support for Heimdal,
+       #####          using this will break the build.  You'll have to make
+       #####          changes to the source, and if you do, please send
+       #####          patches to openssl-dev@openssl.org
+       if ($withargs{"krb5-flavor"} =~ /^force-[Hh]eimdal$/)
+               {
+               warn "Heimdal isn't really supported.  Your build WILL break\n";
+               warn "If you fix the problems, please send a patch to openssl-dev@openssl.org\n";
                $withargs{"krb5-dir"} = "/usr/heimdal"
                        if $withargs{"krb5-dir"} eq "";
                $withargs{"krb5-lib"} = "-L".$withargs{"krb5-dir"}.