Fix determination of Perl interpreter: A perl or perl5
authorRalf S. Engelschall <rse@openssl.org>
Thu, 10 Jun 1999 08:13:52 +0000 (08:13 +0000)
committerRalf S. Engelschall <rse@openssl.org>
Thu, 10 Jun 1999 08:13:52 +0000 (08:13 +0000)
_directory_ in $PATH was also accepted as the interpreter.

CHANGES
Configure

diff --git a/CHANGES b/CHANGES
index 799ff10..28e929c 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,9 +2,12 @@
  OpenSSL CHANGES
  _______________
 
-
  Changes between 0.9.3a and 0.9.4
 
+  *) Fix determination of Perl interpreter: A perl or perl5
+     _directory_ in $PATH was also accepted as the interpreter.
+     [Ralf S. Engelschall]
+
   *) Fix demos/sign/sign.c: well there wasn't anything strictly speaking
      wrong with it but it was very old and did things like calling
      PEM_ASN1_read() directly and used MD5 for the hash not to mention some
index 4c104dd..6271742 100755 (executable)
--- a/Configure
+++ b/Configure
@@ -753,7 +753,7 @@ sub which
        my $path;
        foreach $path (split /:/, $ENV{PATH})
                {
-               if (-x "$path/$name")
+               if (-f "$path/$name" and -x _)
                        {
                        return "$path/$name" unless ($name eq "perl" and
                         system("$path/$name -e " . '\'exit($]<5.0);\''));