Wrong SSL version in DTLS1_BAD_VER ClientHello
authorDavid Woodhouse <dwmw2@infradead.org>
Mon, 2 Mar 2015 16:20:15 +0000 (16:20 +0000)
committerMatt Caswell <matt@openssl.org>
Mon, 9 Mar 2015 11:07:47 +0000 (11:07 +0000)
Since commit 741c9959 ("DTLS revision."), we put the wrong protocol
version into our ClientHello for DTLS1_BAD_VER. The old DTLS
code which used ssl->version was replaced by the more generic SSL3 code
which uses ssl->client_version. The Cisco ASA no longer likes our
ClientHello.

RT#3711

Reviewed-by: Rich Salz <rsalz@openssl.org>
(cherry picked from commit f7683aaf36341dc65672ac2ccdbfd4a232e3626d)

ssl/d1_lib.c

index 2845757..1f10054 100644 (file)
@@ -270,7 +270,7 @@ void dtls1_clear(SSL *s)
 
     ssl3_clear(s);
     if (s->options & SSL_OP_CISCO_ANYCONNECT)
-        s->version = DTLS1_BAD_VER;
+        s->client_version = s->version = DTLS1_BAD_VER;
     else if (s->method->version == DTLS_ANY_VERSION)
         s->version = DTLS1_2_VERSION;
     else