Further OS-X deprecated warnings tweak
authorMatt Caswell <matt@openssl.org>
Sun, 11 Oct 2015 15:59:08 +0000 (16:59 +0100)
committerMatt Caswell <matt@openssl.org>
Fri, 20 Nov 2015 23:35:19 +0000 (23:35 +0000)
Even with _XOPEN_SOURCE defined OS-X still displays warnings that
makecontext and friends are deprecated. This isn't a problem until you
try and build with --strict-warnings, and the build fails. This change
suppresses the warnings. We know they are deprecated but there is no
alternative!

Reviewed-by: Rich Salz <rsalz@openssl.org>
crypto/async/arch/async_posix.h

index 0f91464..d5b2399 100644 (file)
 
 /*
  * Some platforms complain (e.g. OS-X) that setcontext/getcontext/makecontext
- * are deprecated without this defined
+ * are deprecated without the following defined. We know its deprecated but
+ * there is no alternative.
  */
 #  define _XOPEN_SOURCE
+#  pragma GCC diagnostic ignored "-Wdeprecated-declarations"
 
 #  include <ucontext.h>
 #  include <setjmp.h>