make update
[openssl.git] / perl / Makefile.PL
index 77d5af5f21f3f4c01cfe9e88fe5c79928946cf26..2a67ad061d5cefc1c13bcc1d0e6bb8aac32a239a 100644 (file)
@@ -2,18 +2,26 @@
 ##  Makefile.PL -- Perl MakeMaker specification
 ##
 
+open(IN,"<../Makefile.ssl") || die "unable to open Makefile.ssl!\n";
+while(<IN>) {
+    $V=$1 if (/^VERSION=(.*)$/);
+}
+close(IN);
+print "Configuring companion Perl module for OpenSSL $V\n";
+
 use ExtUtils::MakeMaker;
 
 WriteMakefile(
     'OPTIMIZE'      => '',
-    'DISTNAME'      => 'OpenSSL-0.9.2',
+    'DISTNAME'      => "openssl-$V",
     'NAME'          => 'OpenSSL',
     'VERSION_FROM'  => 'OpenSSL.pm',
-    'LIBS'          => ['-L.. -lssl -lcrypto'],
+    'LIBS'          => ( $^O eq 'MSWin32'
+                         ? [ '-L../out32dll -lssleay32 -llibeay32' ]
+                         : [ '-L.. -lssl -lcrypto' ]                 ),
     'DEFINE'        => '',
     'INC'           => '-I../include',
     'H'             => ['openssl.h'],
-    'C'             => ['openssl_cb.c'],
     'OBJECT' =>
         'OpenSSL.o ' .
         'openssl_bio.o ' .