Second round of fixing the OpenSSL perl/ stuff. It now at least compiled fine
[openssl.git] / perl / Makefile.PL
index 77d5af5f21f3f4c01cfe9e88fe5c79928946cf26..1f0c44abbf99423c0c3a55b60d06fbc0a410db75 100644 (file)
@@ -2,14 +2,19 @@
 ##  Makefile.PL -- Perl MakeMaker specification
 ##
 
+$V = '0.9.2';
+print "Configuring companion Perl module for OpenSSL $V\n";
+
 use ExtUtils::MakeMaker;
 
 WriteMakefile(
     'OPTIMIZE'      => '',
-    'DISTNAME'      => 'OpenSSL-0.9.2',
+    'DISTNAME'      => "openssl-$V",
     'NAME'          => 'OpenSSL',
     'VERSION_FROM'  => 'OpenSSL.pm',
-    'LIBS'          => ['-L.. -lssl -lcrypto'],
+    'LIBS'          => ( $^O eq 'MSWin32'
+                         ? [ '-L../out32dll -lssleay32 -llibeay32' ]
+                         : [ '-L.. -lssl -lcrypto' ]                 ),
     'DEFINE'        => '',
     'INC'           => '-I../include',
     'H'             => ['openssl.h'],