Configure option 'no-deprecated' means '-DOPENSSL_API_COMPAT=0x10100000L'
[openssl.git] / include / openssl / opensslconf.h.in
index dc36a74f6d1bb3581107b52eec6b6cda6f1bece2..96f791ec6cc2d573dba905f518aea79eba39fe96 100644 (file)
@@ -68,9 +68,7 @@ extern "C" {
  * still won't see them if the library has been built to disable deprecated
  * functions.
  */
-#if defined(OPENSSL_NO_DEPRECATED)
-# define DECLARE_DEPRECATED(f)
-#elif __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ > 0)
+#if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ > 0)
 # define DECLARE_DEPRECATED(f)    f __attribute__ ((deprecated));
 #else
 # define DECLARE_DEPRECATED(f)   f;