Fix no-deprecated
[openssl.git] / engines / afalg / build.info
index 5336de7..5aba447 100644 (file)
@@ -1,8 +1,15 @@
 {- use File::Spec::Functions qw/:DEFAULT rel2abs/; -}
 
-IF[{- $config{afalg} eq "afalg" -}] 
- ENGINES=libafalg
- SOURCE[libafalg]=e_afalg.c e_afalg_err.c
- DEPEND[libafalg]=../../libcrypto
- INCLUDE[libafalg]= {- rel2abs(catdir($builddir,"../include")) -} ../../include
+IF[{- !$disabled{"engine"} -}]
+  IF[{- !$disabled{afalg} -}]
+    IF[{- $disabled{"dynamic-engine"} -}]
+      LIBS=../../libcrypto
+      SOURCE[../../libcrypto]=e_afalg.c e_afalg_err.c
+    ELSE
+      ENGINES=afalg
+      SOURCE[afalg]=e_afalg.c e_afalg_err.c
+      DEPEND[afalg]=../../libcrypto
+      INCLUDE[afalg]= {- rel2abs(catdir($builddir,"../../include")) -} ../../include
+    ENDIF
+  ENDIF
 ENDIF