Added restrictions on the use of proxy certificates, as they may pose
[openssl.git] / crypto / x509 / x509_txt.c
index 247e7e1..7dd2b76 100644 (file)
@@ -128,6 +128,8 @@ const char *X509_verify_cert_error_string(long n)
                return ("path length constraint exceeded");
        case X509_V_ERR_PROXY_PATH_LENGTH_EXCEEDED:
                return("proxy path length constraint exceeded");
+       case X509_V_ERR_PROXY_CERTIFICATES_NOT_ALLOWED:
+               return("proxy cerificates not allowed, please set the appropriate flag");
        case X509_V_ERR_INVALID_PURPOSE:
                return ("unsupported certificate purpose");
        case X509_V_ERR_CERT_UNTRUSTED: