Make sure that NO-RSA applications etc can include evp.h
[openssl.git] / crypto / evp / evp.h
index 6c0275b9e28abb46df60eab9716fa140ee064e80..16e3719a458975cb990140df248395ccd5a0aeb4 100644 (file)
 #ifndef HEADER_ENVELOPE_H
 #define HEADER_ENVELOPE_H
 
+#ifdef OPENSSL_ALGORITHM_DEFINES
+# include <openssl/opensslconf.h>
+#else
+# define OPENSSL_ALGORITHM_DEFINES
+# include <openssl/opensslconf.h>
+# undef OPENSSL_ALGORITHM_DEFINES
+#endif
+
 #ifndef NO_MD2
 #include <openssl/md2.h>
 #endif