Update source files for pre-3.0 deprecation
[openssl.git] / crypto / dsa / dsa_depr.c
index b852fc7..2b363e2 100644 (file)
@@ -1,7 +1,7 @@
 /*
  * Copyright 2002-2016 The OpenSSL Project Authors. All Rights Reserved.
  *
 /*
  * Copyright 2002-2016 The OpenSSL Project Authors. All Rights Reserved.
  *
- * Licensed under the OpenSSL license (the "License").  You may not use
+ * Licensed under the Apache License 2.0 (the "License").  You may not use
  * this file except in compliance with the License.  You can obtain a copy
  * in the file LICENSE in the source distribution or at
  * https://www.openssl.org/source/license.html
  * this file except in compliance with the License.  You can obtain a copy
  * in the file LICENSE in the source distribution or at
  * https://www.openssl.org/source/license.html
@@ -20,7 +20,7 @@
 #define xxxHASH    EVP_sha1()
 
 #include <openssl/opensslconf.h>
 #define xxxHASH    EVP_sha1()
 
 #include <openssl/opensslconf.h>
-#if OPENSSL_API_COMPAT >= 0x00908000L
+#ifdef OPENSSL_NO_DEPRECATED_0_9_8
 NON_EMPTY_TRANSLATION_UNIT
 #else
 
 NON_EMPTY_TRANSLATION_UNIT
 #else
 
@@ -30,7 +30,6 @@ NON_EMPTY_TRANSLATION_UNIT
 # include <openssl/evp.h>
 # include <openssl/bn.h>
 # include <openssl/dsa.h>
 # include <openssl/evp.h>
 # include <openssl/bn.h>
 # include <openssl/dsa.h>
-# include <openssl/rand.h>
 # include <openssl/sha.h>
 
 DSA *DSA_generate_parameters(int bits,
 # include <openssl/sha.h>
 
 DSA *DSA_generate_parameters(int bits,