Update HPUX config, work around HPUX library incompatibility.
[openssl.git] / config
diff --git a/config b/config
index 5f3446b..eec90a3 100755 (executable)
--- a/config
+++ b/config
@@ -82,8 +82,11 @@ case "${SYSTEM}:${RELEASE}:${VERSION}:${MACHINE}" in
     HP-UX:*)
        HPUXVER=`echo ${RELEASE}|sed -e 's/[^.]*.[0B]*//'`
        case "$HPUXVER" in
+           11.*)
+               echo "${MACHINE}-hp-hpux11"; exit 0
+               ;;
            10.*)
-               echo "${MACHINE}-hp-hpux10."; exit 0
+               echo "${MACHINE}-hp-hpux10"; exit 0
                ;;
            *)
                echo "${MACHINE}-hp-hpux"; exit 0
@@ -310,8 +313,8 @@ case "$GUESSOS" in
   *-*-osf) OUT="alpha-cc" ;;
   *-*-unixware*) OUT="unixware-2.0" ;;
   *-sni-sysv4) OUT="SINIX" ;;
-  *-hpux*) OUT="hpux-$CC" ;;
   # these are all covered by the catchall below
+  # *-hpux*) OUT="hpux-$CC" ;;
   # *-aix) OUT="aix-$CC" ;;
   # *-dgux) OUT="dgux" ;;
   *) OUT=`echo $GUESSOS | awk -F- '{print $3}'`;;