Check the as version on Solaris x86. People don't read INSTALL anyway. :)
[openssl.git] / config
diff --git a/config b/config
index 93e2317..969c94d 100755 (executable)
--- a/config
+++ b/config
@@ -438,6 +438,14 @@ then
   sleep 5
   OUT=linux-sparcv8
 fi
+if [ "$OUT" = "i86pc-sun-solaris2" ]
+then
+  ASM=`as -V /dev/null`
+  case "$ASM" in
+    GNU*) ;;
+    *) options="$options no-asm" ; echo "WARNING: You need the GNU assembler to use OpenSSL assembler code." ; echo "Sun as is not supported on Solaris x86." ;;
+  esac
+fi
 
 case "$GUESSOS" in
   i386-*) options="$options 386" ;;