Add missing define to enable AES-NI usage on x86 platform
[openssl.git] / apps / lib / build.info
1 # Auxiliary program source
2 IF[{- $config{target} =~ /^(?:VC-|mingw|BC-)/ -}]
3   # It's called 'init', but doesn't have much 'init' in it...
4   $AUXLIBAPPSSRC=win32_init.c
5 ENDIF
6 IF[{- $config{target} =~ /^vms-/ -}]
7   $AUXLIBAPPSSRC=vms_term_sock.c vms_decc_argv.c
8 ENDIF
9
10 # Source for libapps
11 $LIBAPPSSRC=apps.c apps_ui.c opt.c fmt.c s_cb.c s_socket.c app_rand.c \
12         columns.c app_params.c names.c app_provider.c app_x509.c http_server.c \
13         engine.c engine_loader.c app_libctx.c
14
15 IF[{- !$disabled{apps} -}]
16   LIBS{noinst}=../libapps.a
17   SOURCE[../libapps.a]=$LIBAPPSSRC $AUXLIBAPPSSRC
18   INCLUDE[../libapps.a]=../.. ../../include ../include
19 ENDIF
20
21 IF[{- !$disabled{srp} -}]
22   SOURCE[../libapps.a]=tlssrp_depr.c
23 ENDIF