Change pq_compat.h to trust the macros defined by bn.h a bit more, and thereby
authorRichard Levitte <levitte@openssl.org>
Sun, 5 Jun 2005 22:42:58 +0000 (22:42 +0000)
committerRichard Levitte <levitte@openssl.org>
Sun, 5 Jun 2005 22:42:58 +0000 (22:42 +0000)
provide better generic support for environments that do not have 64-bit
integers.  Among others, this should solve PR 1086

crypto/pqueue/pq_compat.h

index 2157a54..776760a 100644 (file)
 /* 
  * The purpose of this header file is for supporting 64-bit integer
  * manipulation on 32-bit (and lower) machines.  Currently the only
- * such environment is VMS.  Other environments that do not natively
- * support 64-bit integers can safely use the code developed for VMS.
+ * such environment is VMS, Utrix and those with smaller default integer
+ * sizes than 32 bits.  For all such environment, we fall back to using
+ * BIGNUM.  We may need to fine tune the conditions for systems that
+ * are incorrectly configured.
  *
  * The only clients of this code are (1) pqueue for priority, and
  * (2) DTLS, for sequence number manipulation.
  */
 
-#if defined(OPENSSL_SYS_VMS) || defined(VMS_TEST)
+#if (defined(THIRTY_TWO_BIT) && !defined(BN_LLONG)) || defined(SIXTEEN_BIT) || defined(EIGHT_BIT)
 
 #define PQ_64BIT     BIGNUM
 #define PQ_64BIT_CTX BN_CTX