use saner default parameters for scrypt
[openssl.git] / util / shlib_wrap.sh
index a2f62d6..646b0fe 100755 (executable)
@@ -80,7 +80,7 @@ if [ -f "$LIBCRYPTOSO" -a -z "$preload_var" ]; then
        # it into a script makes it possible to do so on multi-ABI
        # platforms.
        case "$SYSNAME" in
-       *BSD)   LD_PRELOAD="$LIBCRYPTOSO:$LIBSSLSO" ;;  # *BSD
+       *BSD|QNX)       LD_PRELOAD="$LIBCRYPTOSO:$LIBSSLSO" ;;  # *BSD, QNX
        *)      LD_PRELOAD="$LIBCRYPTOSO $LIBSSLSO" ;;  # SunOS, Linux, ELF HP-UX
        esac
        _RLD_LIST="$LIBCRYPTOSO:$LIBSSLSO:DEFAULT"      # Tru64, o32 IRIX
@@ -88,4 +88,10 @@ if [ -f "$LIBCRYPTOSO" -a -z "$preload_var" ]; then
        export LD_PRELOAD _RLD_LIST DYLD_INSERT_LIBRARIES
 fi
 
-exec "$@"
+cmd="$1"; [ -x "$cmd" ] || cmd="$cmd${EXE_EXT}"
+shift
+if [ $# -eq 0 ]; then
+       exec "$cmd"     # old sh, such as Tru64 4.x, fails to expand empty "$@"
+else
+       exec "$cmd" "$@"
+fi