use saner default parameters for scrypt
[openssl.git] / util / shlib_wrap.sh
index 8775cb5..646b0fe 100755 (executable)
@@ -88,7 +88,7 @@ if [ -f "$LIBCRYPTOSO" -a -z "$preload_var" ]; then
        export LD_PRELOAD _RLD_LIST DYLD_INSERT_LIBRARIES
 fi
 
-cmd="$1${EXE_EXT}"
+cmd="$1"; [ -x "$cmd" ] || cmd="$cmd${EXE_EXT}"
 shift
 if [ $# -eq 0 ]; then
        exec "$cmd"     # old sh, such as Tru64 4.x, fails to expand empty "$@"