Make sure ECDSA is built and tested on VMS.
[openssl.git] / test / tests.com
index 07a3c7f..f126e49 100644 (file)
@@ -22,14 +22,16 @@ $       tests := -
        test_des,test_idea,test_sha,test_md4,test_md5,test_hmac,-
        test_md2,test_mdc2,-
        test_rmd,test_rc2,test_rc4,test_rc5,test_bf,test_cast,test_rd,-
-       test_rand,test_bn,test_ec,test_enc,test_x509,test_rsa,test_crl,test_sid,-
+       test_rand,test_bn,test_ec,test_ecdsa,-
+       test_enc,test_x509,test_rsa,test_crl,test_sid,-
        test_gen,test_req,test_pkcs7,test_verify,test_dh,test_dsa,-
-       test_ss,test_ca,test_engine,test_ssl,test_evp
+       test_ss,test_ca,test_engine,test_evp,test_ssl
 $      endif
 $      tests = f$edit(tests,"COLLAPSE")
 $
 $      BNTEST :=       bntest
 $      ECTEST :=       ectest
+$      ECDSATEST :=    ecdsatest
 $      EXPTEST :=      exptest
 $      IDEATEST :=     ideatest
 $      SHATEST :=      shatest
@@ -182,6 +184,10 @@ $ test_ec:
 $      write sys$output "test elliptic curves"
 $      mcr 'texe_dir''ectest'
 $      return
+$ test_ec:
+$      write sys$output "test ecdsa"
+$      mcr 'texe_dir''ecdsatest'
+$      return
 $ test_verify:
 $      write sys$output "The following command should have some OK's and some failures"
 $      write sys$output "There are definitly a few expired certificates"