Richard moved hw_nuron.c over to DSO-land recently, so this include isn't
[openssl.git] / perl / Makefile.PL
index 09eb93653b62a89dd7e9eb4302fcf917f3daf53b..2a67ad061d5cefc1c13bcc1d0e6bb8aac32a239a 100644 (file)
@@ -2,7 +2,11 @@
 ##  Makefile.PL -- Perl MakeMaker specification
 ##
 
-$V = '0.9.2b';
+open(IN,"<../Makefile.ssl") || die "unable to open Makefile.ssl!\n";
+while(<IN>) {
+    $V=$1 if (/^VERSION=(.*)$/);
+}
+close(IN);
 print "Configuring companion Perl module for OpenSSL $V\n";
 
 use ExtUtils::MakeMaker;
@@ -18,7 +22,6 @@ WriteMakefile(
     'DEFINE'        => '',
     'INC'           => '-I../include',
     'H'             => ['openssl.h'],
-    'C'             => ['openssl_cb.c'],
     'OBJECT' =>
         'OpenSSL.o ' .
         'openssl_bio.o ' .