Call fipsas.pl directly for pa-risc targets.
[openssl.git] / crypto / bn / Makefile
index 5115c2afaa5561b74839ecad109ff895949f06de..61b6b702b2d132e73c26004724c879c7a6ee32fe 100644 (file)
@@ -105,9 +105,9 @@ ia64-mont.s:        asm/ia64-mont.pl
 # GNU assembler fails to compile PA-RISC2 modules, insist on calling
 # vendor assembler...
 pa-risc2W.o: asm/pa-risc2W.s
 # GNU assembler fails to compile PA-RISC2 modules, insist on calling
 # vendor assembler...
 pa-risc2W.o: asm/pa-risc2W.s
-       /usr/ccs/bin/as -o pa-risc2W.o asm/pa-risc2W.s
+       $(PERL) $(TOP)/util/fipsas.pl $(TOP) $< /usr/ccs/bin/as -o pa-risc2W.o asm/pa-risc2W.s
 pa-risc2.o: asm/pa-risc2.s
 pa-risc2.o: asm/pa-risc2.s
-       /usr/ccs/bin/as -o pa-risc2.o asm/pa-risc2.s
+       $(PERL) $(TOP)/util/fipsas.pl $(TOP) $< /usr/ccs/bin/as -o pa-risc2.o asm/pa-risc2.s
 
 parisc-mont.s: asm/parisc-mont.pl
        $(PERL) asm/parisc-mont.pl $(PERLASM_SCHEME) $@
 
 parisc-mont.s: asm/parisc-mont.pl
        $(PERL) asm/parisc-mont.pl $(PERLASM_SCHEME) $@