Fix array bounds violation in ssl_session_dup
[openssl.git] / INSTALL
diff --git a/INSTALL b/INSTALL
index a0ebef9..52e3f2a 100644 (file)
--- a/INSTALL
+++ b/INSTALL
 
   enable-ec_nistp_64_gcc_128
                    Enable support for optimised implementations of some commonly
-                   used NIST elliptic curves. This is only supported on some
-                   platforms.
+                   used NIST elliptic curves.
+                   This is only supported on platforms:
+                   - with little-endian storage of non-byte types
+                   - that tolerate misaligned memory references
+                   - where the compiler:
+                     - supports the non-standard type __uint128_t
+                     - defines the built-in macro __SIZEOF_INT128__
 
   enable-egd
                    Build support for gathering entropy from EGD (Entropy