Fix version handling so it can cope with a major version >3.
[openssl.git] / CHANGES
diff --git a/CHANGES b/CHANGES
index 54e643f80f5728340b23863d96e74dbe19227a16..00ea5eecb2fd28d0a6ac734983bf3cf8c52ef86e 100644 (file)
--- a/CHANGES
+++ b/CHANGES
 
  Changes between 0.9.8l (?) and 0.9.8m (?)  [xx XXX xxxx]
 
+  *) Handle TLS versions 2.0 and later properly and correctly use the
+     highest version of TLS/SSL supported. Although TLS >= 2.0 is some way
+     off ancient servers have a habit of sticking around for a while...
+     [Steve Henson]
+
   *) Modify compression code so it frees up structures without using the
      ex_data callbacks. This works around a problem where some applications
      call CRYPTO_free_all_ex_data() before application exit (e.g. when