synchronize with engine-0.9.6 tree
[openssl.git] / openssl.spec
1 %define libmaj 0
2 %define libmin 9
3 %define librel 7
4 #%define librev a
5 Release: 1
6
7 %define openssldir /var/ssl
8
9 Summary: Secure Sockets Layer and cryptography libraries and tools
10 Name: openssl
11 Version: %{libmaj}.%{libmin}.%{librel}
12 #Version: %{libmaj}.%{libmin}.%{librel}%{librev}
13 Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
14 Copyright: Freely distributable
15 Group: System Environment/Libraries
16 Provides: SSL
17 URL: http://www.openssl.org/
18 Packager: Damien Miller <djm@mindrot.org>
19 BuildRoot:   /var/tmp/%{name}-%{version}-root
20
21 %description
22 The OpenSSL Project is a collaborative effort to develop a robust,
23 commercial-grade, fully featured, and Open Source toolkit implementing the
24 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
25 protocols as well as a full-strength general purpose cryptography library.
26 The project is managed by a worldwide community of volunteers that use the
27 Internet to communicate, plan, and develop the OpenSSL tookit and its related
28 documentation. 
29
30 OpenSSL is based on the excellent SSLeay library developed from Eric A.
31 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
32 Apache-style licence, which basically means that you are free to get and
33 use it for commercial and non-commercial purposes. 
34
35 This package contains the base OpenSSL cryptography and SSL/TLS 
36 libraries and tools.
37
38 %package devel
39 Summary: Secure Sockets Layer and cryptography static libraries and headers
40 Group: Development/Libraries
41 Requires: openssl
42 %description devel
43 The OpenSSL Project is a collaborative effort to develop a robust,
44 commercial-grade, fully featured, and Open Source toolkit implementing the
45 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
46 protocols as well as a full-strength general purpose cryptography library.
47 The project is managed by a worldwide community of volunteers that use the
48 Internet to communicate, plan, and develop the OpenSSL tookit and its related
49 documentation. 
50
51 OpenSSL is based on the excellent SSLeay library developed from Eric A.
52 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
53 Apache-style licence, which basically means that you are free to get and
54 use it for commercial and non-commercial purposes. 
55
56 This package contains the the OpenSSL cryptography and SSL/TLS 
57 static libraries and header files required when developing applications.
58
59 %package doc
60 Summary: OpenSSL miscellaneous files
61 Group: Documentation
62 Requires: openssl
63 %description doc
64 The OpenSSL Project is a collaborative effort to develop a robust,
65 commercial-grade, fully featured, and Open Source toolkit implementing the
66 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
67 protocols as well as a full-strength general purpose cryptography library.
68 The project is managed by a worldwide community of volunteers that use the
69 Internet to communicate, plan, and develop the OpenSSL tookit and its related
70 documentation. 
71
72 OpenSSL is based on the excellent SSLeay library developed from Eric A.
73 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
74 Apache-style licence, which basically means that you are free to get and
75 use it for commercial and non-commercial purposes. 
76
77 This package contains the the OpenSSL cryptography and SSL/TLS extra
78 documentation and POD files from which the man pages were produced.
79
80 %prep
81
82 %setup -q
83
84 %build 
85
86 %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr 
87
88 perl util/perlpath.pl /usr/bin/perl
89
90 %ifarch i386 i486 i586 i686
91 ./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-elf shared
92 %endif
93 %ifarch ppc
94 ./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-ppc shared
95 %endif
96 %ifarch alpha
97 ./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-alpha shared
98 %endif
99 LD_LIBRARY_PATH=`pwd` make
100 LD_LIBRARY_PATH=`pwd` make rehash
101 LD_LIBRARY_PATH=`pwd` make test
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 make MANDIR=/usr/man INSTALL_PREFIX="$RPM_BUILD_ROOT" install
106
107 # Rename manpages
108 for x in $RPM_BUILD_ROOT/usr/man/man*/* 
109         do mv ${x} ${x}ssl
110 done
111
112 # Make backwards-compatibility symlink to ssleay
113 ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files 
119 %defattr(0644,root,root,0755)
120 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
121
122 %attr(0755,root,root) /usr/bin/*
123 %attr(0755,root,root) /usr/lib/*.so*
124 %attr(0755,root,root) %{openssldir}/misc/*
125 %attr(0644,root,root) /usr/man/man[157]/*
126
127 %config %attr(0644,root,root) %{openssldir}/openssl.cnf 
128 %dir %attr(0755,root,root) %{openssldir}/certs
129 %dir %attr(0755,root,root) %{openssldir}/lib
130 %dir %attr(0755,root,root) %{openssldir}/misc
131 %dir %attr(0750,root,root) %{openssldir}/private
132
133 %files devel
134 %defattr(0644,root,root,0755)
135 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
136
137 %attr(0644,root,root) /usr/lib/*.a
138 %attr(0644,root,root) /usr/include/openssl/*
139 %attr(0644,root,root) /usr/man/man[3]/*
140
141 %files doc
142 %defattr(0644,root,root,0755)
143 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
144 %doc doc
145
146 %post
147 ldconfig
148
149 %postun
150 ldconfig
151
152 %changelog
153 * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
154 - Removed redundant subsection that re-installed libcrypto.a and libssl.a
155   as well.  Also remove RSAref stuff completely, since it's not needed
156   any more.
157 * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
158 - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
159   libssl.so.0.9.6.  As well as the subsection that created symlinks for
160   these.  make install handles all this.
161 * Sat Oct 21 2000 Horms <horms@vergenet.net>
162 - Make sure symlinks are created by using -f flag to ln.
163   Otherwise some .so libraries are copied rather than
164   linked in the resulting binary RPM. This causes the package
165   to be larger than neccessary and makes ldconfig complain.
166 * Fri Oct 13 2000 Horms <horms@vergenet.net>
167 - Make defattr is set for files in all packages so packages built as
168   non-root will still be installed with files owned by root.
169 * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
170 - Changed to adapt to the new (supported) way of making shared libraries
171 - Installs all static libraries, not just libRSAglue.a
172 - Extra documents now end up in a separate document package
173 * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
174 - Merged patches to spec
175 - Updated to 0.9.5beta2 (now with manpages)
176 * Sat Feb  5 2000 Michal Jaegermann <michal@harddata.com>
177 - added 'linux-alpha' to configuration
178 - fixed nasty absolute links
179 * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
180 - Added -DSSL_ALLOW_ADH, bumped Release to 4
181 * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
182 - Set default permissions
183 - Removed documentation from devel sub-package
184 * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
185 - Added "make test" stage
186 - GPG signed
187 * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
188 - Updated to version 0.9.4
189 * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
190 - Updated to version 0.9.3
191 - Added attributes for all files
192 - Paramatised openssl directory
193 * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
194 - Added "official" bnrec patch and taking other out
195 - making a link from ssleay to openssl binary
196 - putting all changelog together on SPEC file
197 * Fri Mar  5 1999 Henri Gomez <gomez@slib.fr>
198 - Added bnrec patch
199 * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
200 - minimum spec and patches changes for openssl
201 - modified for openssl sources
202 * Sat Aug  8 1998 Khimenko Victor <khim@sch57.msk.ru>
203 - shared library creating process honours $RPM_OPT_FLAGS
204 - shared libarry supports threads (as well as static library)
205 * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
206 - building of shared library completely reworked
207 * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
208 - RPM is BuildRoot'ed
209 * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
210 - all stuff is moved out of /usr/local