Update docs.
[openssl.git] / openssl.spec
1 %define libmaj 0
2 %define libmin 9
3 %define librel 8
4 #%define librev a
5 Release: 1
6
7 %define openssldir /var/ssl
8
9 Summary: Secure Sockets Layer and cryptography libraries and tools
10 Name: openssl
11 Version: %{libmaj}.%{libmin}.%{librel}
12 #Version: %{libmaj}.%{libmin}.%{librel}%{librev}
13 Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
14 Copyright: Freely distributable
15 Group: System Environment/Libraries
16 Provides: SSL
17 URL: http://www.openssl.org/
18 Packager: Damien Miller <djm@mindrot.org>
19 BuildRoot:   /var/tmp/%{name}-%{version}-root
20
21 %description
22 The OpenSSL Project is a collaborative effort to develop a robust,
23 commercial-grade, fully featured, and Open Source toolkit implementing the
24 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
25 protocols as well as a full-strength general purpose cryptography library.
26 The project is managed by a worldwide community of volunteers that use the
27 Internet to communicate, plan, and develop the OpenSSL tookit and its related
28 documentation. 
29
30 OpenSSL is based on the excellent SSLeay library developed from Eric A.
31 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
32 Apache-style licence, which basically means that you are free to get and
33 use it for commercial and non-commercial purposes. 
34
35 This package contains the base OpenSSL cryptography and SSL/TLS 
36 libraries and tools.
37
38 %package devel
39 Summary: Secure Sockets Layer and cryptography static libraries and headers
40 Group: Development/Libraries
41 Requires: openssl
42 %description devel
43 The OpenSSL Project is a collaborative effort to develop a robust,
44 commercial-grade, fully featured, and Open Source toolkit implementing the
45 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
46 protocols as well as a full-strength general purpose cryptography library.
47 The project is managed by a worldwide community of volunteers that use the
48 Internet to communicate, plan, and develop the OpenSSL tookit and its related
49 documentation. 
50
51 OpenSSL is based on the excellent SSLeay library developed from Eric A.
52 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
53 Apache-style licence, which basically means that you are free to get and
54 use it for commercial and non-commercial purposes. 
55
56 This package contains the the OpenSSL cryptography and SSL/TLS 
57 static libraries and header files required when developing applications.
58
59 %package doc
60 Summary: OpenSSL miscellaneous files
61 Group: Documentation
62 Requires: openssl
63 %description doc
64 The OpenSSL Project is a collaborative effort to develop a robust,
65 commercial-grade, fully featured, and Open Source toolkit implementing the
66 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
67 protocols as well as a full-strength general purpose cryptography library.
68 The project is managed by a worldwide community of volunteers that use the
69 Internet to communicate, plan, and develop the OpenSSL tookit and its related
70 documentation. 
71
72 OpenSSL is based on the excellent SSLeay library developed from Eric A.
73 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
74 Apache-style licence, which basically means that you are free to get and
75 use it for commercial and non-commercial purposes. 
76
77 This package contains the the OpenSSL cryptography and SSL/TLS extra
78 documentation and POD files from which the man pages were produced.
79
80 %prep
81
82 %setup -q
83
84 %build 
85
86 %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr --openssldir=%{openssldir}
87
88 perl util/perlpath.pl /usr/bin/perl
89
90 %ifarch i386 i486 i586 i686
91 ./Configure %{CONFIG_FLAGS} linux-elf shared
92 %endif
93 %ifarch ppc
94 ./Configure %{CONFIG_FLAGS} linux-ppc shared
95 %endif
96 %ifarch alpha
97 ./Configure %{CONFIG_FLAGS} linux-alpha shared
98 %endif
99 LD_LIBRARY_PATH=`pwd` make
100 LD_LIBRARY_PATH=`pwd` make rehash
101 LD_LIBRARY_PATH=`pwd` make test
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 make MANDIR=/usr/man MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
106
107 # Make backwards-compatibility symlink to ssleay
108 ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files 
114 %defattr(0644,root,root,0755)
115 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
116
117 %attr(0755,root,root) /usr/bin/*
118 %attr(0755,root,root) /usr/lib/*.so*
119 %attr(0755,root,root) %{openssldir}/misc/*
120 %attr(0644,root,root) /usr/man/man[157]/*
121
122 %config %attr(0644,root,root) %{openssldir}/openssl.cnf 
123 %dir %attr(0755,root,root) %{openssldir}/certs
124 %dir %attr(0755,root,root) %{openssldir}/lib
125 %dir %attr(0755,root,root) %{openssldir}/misc
126 %dir %attr(0750,root,root) %{openssldir}/private
127
128 %files devel
129 %defattr(0644,root,root,0755)
130 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
131
132 %attr(0644,root,root) /usr/lib/*.a
133 %attr(0644,root,root) /usr/lib/pkgconfig/openssl.pc
134 %attr(0644,root,root) /usr/include/openssl/*
135 %attr(0644,root,root) /usr/man/man[3]/*
136
137 %files doc
138 %defattr(0644,root,root,0755)
139 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
140 %doc doc
141
142 %post
143 ldconfig
144
145 %postun
146 ldconfig
147
148 %changelog
149 * Wed May  7 2003 Richard Levitte <richard@levitte.org>
150 - Add /usr/lib/pkgconfig/openssl.pc to the development section.
151 * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
152 - Removed redundant subsection that re-installed libcrypto.a and libssl.a
153   as well.  Also remove RSAref stuff completely, since it's not needed
154   any more.
155 * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
156 - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
157   libssl.so.0.9.6.  As well as the subsection that created symlinks for
158   these.  make install handles all this.
159 * Sat Oct 21 2000 Horms <horms@vergenet.net>
160 - Make sure symlinks are created by using -f flag to ln.
161   Otherwise some .so libraries are copied rather than
162   linked in the resulting binary RPM. This causes the package
163   to be larger than neccessary and makes ldconfig complain.
164 * Fri Oct 13 2000 Horms <horms@vergenet.net>
165 - Make defattr is set for files in all packages so packages built as
166   non-root will still be installed with files owned by root.
167 * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
168 - Changed to adapt to the new (supported) way of making shared libraries
169 - Installs all static libraries, not just libRSAglue.a
170 - Extra documents now end up in a separate document package
171 * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
172 - Merged patches to spec
173 - Updated to 0.9.5beta2 (now with manpages)
174 * Sat Feb  5 2000 Michal Jaegermann <michal@harddata.com>
175 - added 'linux-alpha' to configuration
176 - fixed nasty absolute links
177 * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
178 - Added -DSSL_ALLOW_ADH, bumped Release to 4
179 * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
180 - Set default permissions
181 - Removed documentation from devel sub-package
182 * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
183 - Added "make test" stage
184 - GPG signed
185 * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
186 - Updated to version 0.9.4
187 * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
188 - Updated to version 0.9.3
189 - Added attributes for all files
190 - Paramatised openssl directory
191 * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
192 - Added "official" bnrec patch and taking other out
193 - making a link from ssleay to openssl binary
194 - putting all changelog together on SPEC file
195 * Fri Mar  5 1999 Henri Gomez <gomez@slib.fr>
196 - Added bnrec patch
197 * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
198 - minimum spec and patches changes for openssl
199 - modified for openssl sources
200 * Sat Aug  8 1998 Khimenko Victor <khim@sch57.msk.ru>
201 - shared library creating process honours $RPM_OPT_FLAGS
202 - shared libarry supports threads (as well as static library)
203 * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
204 - building of shared library completely reworked
205 * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
206 - RPM is BuildRoot'ed
207 * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
208 - all stuff is moved out of /usr/local