Use default point formats extension for server side as well as client
[openssl.git] / openssl.spec
1 %define _unpackaged_files_terminate_build 0
2 %define libmaj 1
3 %define libmin 1
4 %define librel 0
5 #%define librev a
6 Release: 1
7
8 %define openssldir /var/ssl
9
10 Summary: Secure Sockets Layer and cryptography libraries and tools
11 Name: openssl
12 Version: %{libmaj}.%{libmin}.%{librel}
13 #Version: %{libmaj}.%{libmin}.%{librel}%{librev}
14 Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
15 Copyright: Freely distributable
16 Group: System Environment/Libraries
17 Provides: SSL
18 URL: http://www.openssl.org/
19 Packager: Damien Miller <djm@mindrot.org>
20 BuildRoot:   /var/tmp/%{name}-%{version}-root
21
22 %description
23 The OpenSSL Project is a collaborative effort to develop a robust,
24 commercial-grade, fully featured, and Open Source toolkit implementing the
25 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
26 protocols as well as a full-strength general purpose cryptography library.
27 The project is managed by a worldwide community of volunteers that use the
28 Internet to communicate, plan, and develop the OpenSSL tookit and its related
29 documentation. 
30
31 OpenSSL is based on the excellent SSLeay library developed from Eric A.
32 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
33 Apache-style licence, which basically means that you are free to get and
34 use it for commercial and non-commercial purposes. 
35
36 This package contains the base OpenSSL cryptography and SSL/TLS 
37 libraries and tools.
38
39 %package devel
40 Summary: Secure Sockets Layer and cryptography static libraries and headers
41 Group: Development/Libraries
42 Requires: openssl
43 %description devel
44 The OpenSSL Project is a collaborative effort to develop a robust,
45 commercial-grade, fully featured, and Open Source toolkit implementing the
46 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
47 protocols as well as a full-strength general purpose cryptography library.
48 The project is managed by a worldwide community of volunteers that use the
49 Internet to communicate, plan, and develop the OpenSSL tookit and its related
50 documentation. 
51
52 OpenSSL is based on the excellent SSLeay library developed from Eric A.
53 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
54 Apache-style licence, which basically means that you are free to get and
55 use it for commercial and non-commercial purposes. 
56
57 This package contains the the OpenSSL cryptography and SSL/TLS 
58 static libraries and header files required when developing applications.
59
60 %package doc
61 Summary: OpenSSL miscellaneous files
62 Group: Documentation
63 Requires: openssl
64 %description doc
65 The OpenSSL Project is a collaborative effort to develop a robust,
66 commercial-grade, fully featured, and Open Source toolkit implementing the
67 Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
68 protocols as well as a full-strength general purpose cryptography library.
69 The project is managed by a worldwide community of volunteers that use the
70 Internet to communicate, plan, and develop the OpenSSL tookit and its related
71 documentation. 
72
73 OpenSSL is based on the excellent SSLeay library developed from Eric A.
74 Young and Tim J. Hudson.  The OpenSSL toolkit is licensed under an
75 Apache-style licence, which basically means that you are free to get and
76 use it for commercial and non-commercial purposes. 
77
78 This package contains the the OpenSSL cryptography and SSL/TLS extra
79 documentation and POD files from which the man pages were produced.
80
81 %prep
82
83 %setup -q
84
85 %build 
86
87 %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr --openssldir=%{openssldir}
88
89 perl util/perlpath.pl /usr/bin/perl
90
91 %ifarch i386 i486 i586 i686
92 ./Configure %{CONFIG_FLAGS} linux-elf shared
93 %endif
94 %ifarch ppc
95 ./Configure %{CONFIG_FLAGS} linux-ppc shared
96 %endif
97 %ifarch alpha
98 ./Configure %{CONFIG_FLAGS} linux-alpha shared
99 %endif
100 %ifarch x86_64
101 ./Configure %{CONFIG_FLAGS} linux-x86_64 shared
102 %endif
103 LD_LIBRARY_PATH=`pwd` make
104 LD_LIBRARY_PATH=`pwd` make rehash
105 LD_LIBRARY_PATH=`pwd` make test
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 make MANDIR=/usr/man MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
110
111 # Make backwards-compatibility symlink to ssleay
112 ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %files 
118 %defattr(0644,root,root,0755)
119 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
120
121 %attr(0755,root,root) /usr/bin/*
122 %attr(0755,root,root) /usr/lib/*.so*
123 %attr(0755,root,root) %{openssldir}/misc/*
124 %attr(0644,root,root) /usr/man/man[157]/*
125
126 %config %attr(0644,root,root) %{openssldir}/openssl.cnf 
127 %dir %attr(0755,root,root) %{openssldir}/certs
128 %dir %attr(0755,root,root) %{openssldir}/misc
129 %dir %attr(0750,root,root) %{openssldir}/private
130
131 %files devel
132 %defattr(0644,root,root,0755)
133 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
134
135 %attr(0644,root,root) /usr/lib/*.a
136 %attr(0644,root,root) /usr/lib/pkgconfig/openssl.pc
137 %attr(0644,root,root) /usr/include/openssl/*
138 %attr(0644,root,root) /usr/man/man[3]/*
139
140 %files doc
141 %defattr(0644,root,root,0755)
142 %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
143 %doc doc
144
145 %post
146 ldconfig
147
148 %postun
149 ldconfig
150
151 %changelog
152 * Sun Jun  6 2005 Richard Levitte <richard@levitte.org>
153 - Remove the incorrect installation of '%{openssldir}/lib'.
154 * Wed May  7 2003 Richard Levitte <richard@levitte.org>
155 - Add /usr/lib/pkgconfig/openssl.pc to the development section.
156 * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
157 - Removed redundant subsection that re-installed libcrypto.a and libssl.a
158   as well.  Also remove RSAref stuff completely, since it's not needed
159   any more.
160 * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
161 - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
162   libssl.so.0.9.6.  As well as the subsection that created symlinks for
163   these.  make install handles all this.
164 * Sat Oct 21 2000 Horms <horms@vergenet.net>
165 - Make sure symlinks are created by using -f flag to ln.
166   Otherwise some .so libraries are copied rather than
167   linked in the resulting binary RPM. This causes the package
168   to be larger than neccessary and makes ldconfig complain.
169 * Fri Oct 13 2000 Horms <horms@vergenet.net>
170 - Make defattr is set for files in all packages so packages built as
171   non-root will still be installed with files owned by root.
172 * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
173 - Changed to adapt to the new (supported) way of making shared libraries
174 - Installs all static libraries, not just libRSAglue.a
175 - Extra documents now end up in a separate document package
176 * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
177 - Merged patches to spec
178 - Updated to 0.9.5beta2 (now with manpages)
179 * Sat Feb  5 2000 Michal Jaegermann <michal@harddata.com>
180 - added 'linux-alpha' to configuration
181 - fixed nasty absolute links
182 * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
183 - Added -DSSL_ALLOW_ADH, bumped Release to 4
184 * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
185 - Set default permissions
186 - Removed documentation from devel sub-package
187 * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
188 - Added "make test" stage
189 - GPG signed
190 * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
191 - Updated to version 0.9.4
192 * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
193 - Updated to version 0.9.3
194 - Added attributes for all files
195 - Paramatised openssl directory
196 * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
197 - Added "official" bnrec patch and taking other out
198 - making a link from ssleay to openssl binary
199 - putting all changelog together on SPEC file
200 * Fri Mar  5 1999 Henri Gomez <gomez@slib.fr>
201 - Added bnrec patch
202 * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
203 - minimum spec and patches changes for openssl
204 - modified for openssl sources
205 * Sat Aug  8 1998 Khimenko Victor <khim@sch57.msk.ru>
206 - shared library creating process honours $RPM_OPT_FLAGS
207 - shared libarry supports threads (as well as static library)
208 * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
209 - building of shared library completely reworked
210 * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
211 - RPM is BuildRoot'ed
212 * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
213 - all stuff is moved out of /usr/local