Add solaris assembler fixes for legacy provider
[openssl.git] / crypto / des / build.info
1 $DESASM=des_enc.c fcrypt_b.c
2 IF[{- !$disabled{asm} -}]
3   $DESASM_x86=des-586.s crypt586.s
4   $DESASM_ia64=ghash-ia64.s
5   $DESASM_sparcv9=des_enc-sparc.S fcrypt_b.c dest4-sparcv9.S
6   $DESASM_sparcv8=des_enc-sparc.S fcrypt_b.c
7
8   # Now that we have defined all the arch specific variables, use the
9   # appropriate one
10   IF[$DESASM_{- $target{asm_arch} -}]
11     $DESASM=$DESASM_{- $target{asm_arch} -}
12     $DESDEF=DES_ASM
13   ENDIF
14 ENDIF
15
16 LIBS=../../libcrypto
17 $COMMON=set_key.c ecb3_enc.c
18 $ALL=$COMMON\
19      ecb_enc.c  cbc_enc.c \
20      cfb64enc.c cfb64ede.c cfb_enc.c \
21      ofb64ede.c ofb64enc.c ofb_enc.c \
22      str2key.c  pcbc_enc.c qud_cksm.c rand_key.c \
23      fcrypt.c xcbc_enc.c cbc_cksm.c
24
25 SOURCE[../../libcrypto]=$ALL $DESASM
26 SOURCE[../../providers/libfips.a]=$COMMON $DESASM
27 SOURCE[../../providers/liblegacy.a]=$DESASM
28
29 DEFINE[../../libcrypto]=$DESDEF
30 DEFINE[../../providers/libfips.a]=$DESDEF
31 DEFINE[../../providers/liblegacy.a]=$DESDEF
32
33 # When all deprecated symbols are removed, libcrypto doesn't export the
34 # DES functions, so we must include them directly in liblegacy.a
35 IF[{- $disabled{'deprecated-3.0'} && !$disabled{"mdc2"} -}]
36   SOURCE[../../providers/liblegacy.a]=$ALL
37   DEFINE[../../providers/liblegacy.a]=$DESDEF
38 ENDIF
39
40 GENERATE[des_enc-sparc.S]=asm/des_enc.m4
41 GENERATE[dest4-sparcv9.S]=asm/dest4-sparcv9.pl
42 INCLUDE[dest4-sparcv9.o]=..
43
44 GENERATE[des-586.s]=asm/des-586.pl
45 DEPEND[des-586.s]=../perlasm/x86asm.pl ../perlasm/cbc.pl
46 GENERATE[crypt586.s]=asm/crypt586.pl
47 DEPEND[crypt586.s]=../perlasm/x86asm.pl ../perlasm/cbc.pl