revert PR#2755: it breaks compilation
[openssl.git] / openssl.spec
index 03fae0b5b8e66b2a0b33335c91a12712d270afbc..f7c46fdb447a2e3862b0d7ef68aaf8b2d5c5cf22 100644 (file)
@@ -1,15 +1,16 @@
+%define _unpackaged_files_terminate_build 0
 %define libmaj 0
 %define libmin 9
 %define librel 8
-#%define librev a
-Release: 3
+%define librev u
+Release: 1
 
 %define openssldir /var/ssl
 
 Summary: Secure Sockets Layer and cryptography libraries and tools
 Name: openssl
-Version: %{libmaj}.%{libmin}.%{librel}
-#Version: %{libmaj}.%{libmin}.%{librel}%{librev}
+#Version: %{libmaj}.%{libmin}.%{librel}
+Version: %{libmaj}.%{libmin}.%{librel}%{librev}
 Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
 Copyright: Freely distributable
 Group: System Environment/Libraries
@@ -96,6 +97,9 @@ perl util/perlpath.pl /usr/bin/perl
 %ifarch alpha
 ./Configure %{CONFIG_FLAGS} linux-alpha shared
 %endif
+%ifarch x86_64
+./Configure %{CONFIG_FLAGS} linux-x86_64 shared
+%endif
 LD_LIBRARY_PATH=`pwd` make
 LD_LIBRARY_PATH=`pwd` make rehash
 LD_LIBRARY_PATH=`pwd` make test